2008年7月13日 星期日

[ubuntu] 自行編譯 gcin 1.4.2

ubuntu 內建的 gcin 是 1.3.7 版,已經有點舊了
而在gcin 同好會裡,能下載到的deb檔,最新的只有 1.4.0
debian 中的 1.4.2 因為 libpango 的版本相依性關性無法安裝
只好自己編譯了

取得最新版本原始碼
wget http://cle.linux.org.tw/gcin/download/gcin-1.4.2.tar.bz2
tar xvf gcin-1.4.2.tar.bz2


安裝必須的編譯套件
sudo apt-get build-dep gcin

由於 ubuntu 的部份設定和原作者的環境不同,所以必須先修正部份檔案
1. 修改configure檔案,
找到 QT_IM_DIR=/usr/lib/$i/plugins/$LIB/inputmethods
改為 QT_IM_DIR=/usr/lib/$i/plugins/inputmethods

2. 修改 qt-im目錄中的 Makefile
找到 /usr/lib/$(QT)/bin/moc $< -o $<_moc.cpp
改為 moc $< -o $<_moc.cpp

3. 在 /usr/lib/qt3 增加 連結到 /usr/include/qt3
ln -s /usr/include/qt3 /usr/lib/qt3/include

一切準備就序後,就可以開始編譯囉
./configure --prefix=/usr
make
sudo make install

0 回應:

 
TEMPLATE HACKS AND TWEAKS BY [ METAMUSE ] BLACKCAT 1.1